Dead Silent, Dead Battery, Dead Stupid

The 2m section of my Icom IC-706mkII has finally died. Unfortunately, it picked a wrong time to go out: the moment I hit the interstate to head up to the Belton Hamfest. Helluva time to be without a voice, but oh well. Luckily, I had my Baofeng UV-82HP on hand and a connector for the magmount.

The fan mod I did on the Icom was too little, too late. The transistor was probably already on the ragged edge of viability, and I had the habit of running it at full power (20W) for the local repeaters (tsk-tsk), but even with power dialed back, it still had strange issues. I think the 706 just didn’t take too well to being a mobile rig in this Texas heat.

The final behavior is that when PTT was pressed, the power indicator would go to maximum, the transmit light turned red, and no actual signal was emitted (no kerchunk returned). With the dome light on, I could detect a definite power sag with the light dimming when I pushed PTT, so that tells me the transistor was likely just shorting the rails and slurring the signal enough to not really be readable by anything.

My best hope now is that the HF section is still OK, since I seldom used it in the car. I’ve pulled the radio; it’s back in the house. I’ll check it out and see if I can still use it as a backup/portable HF rig.

In the meanwhile, I’ve accelerated my plan to replace it with the Yaesu FT-8500 I bought months ago (I mean, who’s really got the time?). Well now I have all the impetus to get it installed, and boy have I. Thankfully, the extension kit fits the car, and I didn’t have to make any modifications to fit it to my gooseneck mount. Easy-peasy.

However, programming this in bulk is going to be a bitch, since Yaesu’s menuing system is deep. I just wish I could figure out a PC programming solution. But that’s another battle for another day.

The current battle, though, is one that is sneaky, and there are very few references to it online. But, once I figured out the magic words, I found a few newsgroup posts where other hams with the same radio talked about the FT-8500 forgetting its most recent frequency and mode if it is powered down more than 30 seconds. Every time you power it on, it starts in VFO mode with a pair of frequencies that aren’t in any sort of memory, and the UHF section has primary status, with squelch open on both sections. The only way out of that is to either dial another frequency, or press “D/MR” to switch to a memory channel after manually clicking the VHF knob. Complete bullshit, really.

Well, what the user manual never tells you is that the stupid radio has a hidden CR2016 coin cell behind the faceplate. Yeah, it has a battery. Not for the memories: those are stored in EEPROM. It stores the most recent state (frequency, mode, main channel status, etc.) between power-ons.  Without it, you have to manually power it on when car power is restored, manually select the VHF section, and manually select a memory channel to make it operational.

All this time, I had thought it was either a defect, a usability quirk in design, or a secret option setting that wasn’t in any published docs. Nope, it’s just that fucking CR2016 battery with solder tabs that has drained in the X years since the previous owner used the radio.

I gotta take the radio back out of the car, disassemble it, desolder the battery, take it to the battery store for a replacement, have them weld new tabs on, and then take it back home to replace, reassemble, and reinstall. Pain in the ass.

Radio is hard.