Icom IC-706mkII Fan Mod

My mobile rig is an Icom IC-706mkII HF/2m unit that’s been doing me well for months, semi-permanently installed in the car. Lately I’ve been noticing signs of its deterioration, getting signal reports that I’m either cutting out or the audio has a sporadic “electric shock” sound. I’ve been trying like hell to track it down, thinking my custom power cables were either sub-par, that my car’s electrical system (battery, alternator, regulator) were getting edgy, or that my final transistors were starting to fry. All of those options were scary to consider.

The symptoms exhibit more strongly when it’s hot outside and I’m chatting away on a local repeater on the afternoon commute. Eventually, the radio starts freaking out and I have to sign off.

As it turns out, my radio is overheating. The internal fan’s not doing its job.

I took it inside for examination. With the covers off, I put the radio on CW mode, half power, into a dummy load, and held down the key. The fan would only run while I had the key or PTT down, and never outside of that. Even when it was key-down, the fan took a long time to kick over; the driver circuit would attempt to start the fan, but didn’t have enough voltage to push the fan blades except after a few kickover attempts. So it never gets cooling if my talk times are less than 15 seconds (and the heat builds up over the QSO). I was afraid the fan was dying, but when I removed it and drove it with 12v, it blew like a champ (thankfully). So something is wrong with the fan-control thermal circuit.

I found a few references on various radio boards where others have had the same symptom on their own Icom IC-706mkII (and the mkIIg as well). Apparently, the original Icom IC-706 was designed so that the fan would blow constantly. When they designed the mkII and mkIIg, they added a fan circuit to limit the noise and current drain. Unfortunately, once that circuit gets marginal, it stops being useful and actually contributes to the radio’s demise.

Among the references is a rework involving the addition of a 200Ω 1W resistor between L50 and J2 (on the IC-706mkII, at least) which will provide a constant voltage to keep the fan moving at a slower speed. The benefit is that the fan controller won’t need to start the fan; it just ramps up to the right speed.

Two 100 ohm 1W resistors in series for 200 ohms (identified by screwdriver tip), wired between Vcc and the fan.

I soldered a pair of 100Ω in series and shrinkwrapped all connections so they don’t contact the radio circuit (I left the body of the resistors uncovered for cooling), then flew the rework over the board between solder points. It doesn’t appear to wobble or vibrate much, and there’s enough cooling inside that hot case to keep it from frying.

Orange wire (identified by screwdriver tip) soldered to coil L50.
Orange wire (identified by screwdriver tip) soldered to hot side of fan connector J2.

It’s been a week since the rework, and the radio’s still doing OK in the car. I’m still getting spurious reports of noise, but I think my radio’s got an EMI sensitivity when I drive near electric utility substations (EMI/RFI has always been a problem with my 706). But otherwise, it’s doing alright.

It sucks when we have to modify a production device due to engineering mistakes, but thankfully we have the public resources to help us find our way and stay on the air.

One Reply to “Icom IC-706mkII Fan Mod”

Comments are closed.